This page last changed on Jan 26, 2010 by jdeolive.

This update patches a GeoServer 1.7.x installation and provides the ability to configure access control for RESTful services. This includes the restconfig plugin.

It is strongly recommended that the GeoServer be upgraded to the latest 1.7.x release, which is 1.7.7. This patch is not guaranteed to work with older 1.7.x versions.

To apply the patch:

  1. Download rest_security_patch.zip
  2. Navigate to the WEB-INF/lib folder of the GeoServer installation
  3. Back up the existing main-1.7.?.jar and remove it from the WEB-INF/lib directory
  4. Unpack the zip file into the WEB-INF/lib directory.
  5. Review the REST security documentation

Note that by applying this patch all operations, including GET, to RESTful services will require authentication. See the documentation for information on how to configure which operations require authentication.


rest_security_patch.zip (application/zip)
Document generated by Confluence on May 14, 2014 23:00